Klappt garantiert: OpenVPN Client mit Windows 8 – Keine Probleme beim Verbinden

OpenVPN Client macht unter Windows 8 bei bestimmten Konfigurationen Probleme

Es kann passieren, dass OpenVPN Client unter Windows 8 Probleme bei der Einwahl macht. Im Internet findet man dann oft nur den Rat den Client mit Admin-Rechten und womöglich im Windows 7 Kompatibilätsmodus zu starten. Unter Umständen ist aber noch eine Kleinigkeit notwendig. Wenn Sie alle Einstellungen wie unten erklärt vornehmen, sollte es keine Probleme mehr beim Verbinden von OpenVPN Client unter Windows 8 geben.

Stellen Sie zunächst sicher, dass Sie die aktuellste Version von OpenVPN GUI benutzen. Aktuell (Stand Oktober 2012) ist das die Version OpenVPN 2.3_rc1. Aktuell (Stand Februar 2013) ist das die Version OpenVPN 2.3.0 (http://openvpn.net/index.php/open-source/downloads.html)

Klicken Sie zunächst mit der rechten Maustaste auf das Programm-Icon der OpenVPN GUI und wählen den Menüpunkt „Eigenschaften“ aus:

Eigenschaften von OpenVPN Client GUI aufrufen

Eigenschaften von OpenVPN Client GUI aufrufen

 

Wechseln Sie nun in den Reiter „Kompatibilität“ und wählen im Bereich „Kompatibilitätsmodus“ den Menüpunkt „Windows 7“ aus. Stellen Sie außerdem sicher, dass im Bereich „Berechtigungsstufe“ „Programm als Administrator ausführen“ ausgewählt ist:

OpenVPN GUI mit höheren Rechten ausstatten

OpenVPN GUI mit höheren Rechten ausstatten

 

Hinweis:

Wenn an Ihrem Computer mehrere Benutzer arbeiten und Sie diese Einstellung global (also für alle Benutzer) ändern wollen, dann klicken Sie vor dem Bestätigen mit „OK“ auf den Button „Einstellungen für alle Benutzer ändern“. Ansonsten gilt die Änderung nur für den aktuell angemeldeten Benutzer.

 

Nun müssen Sie noch in der Computerverwaltung („Windows-Taste“ und „R“ drücken und „compmgmt.msc“ eingeben) auf der linken Seite den Bereich „Dienste und Anwendungen“ -> „Dienste“ aufrufen und dann auf der rechten Seite den Dienst „Netzwerkverbindungen“ auswählen:

In der Computerverwaltung den Dienst Netzwerkverbindungen auswählen

In der Computerverwaltung den Dienst Netzwerkverbindungen auswählen

 

Als letztes müssen Sie die Startart des Dienstes mit Doppelklick ändern. Wählen Sie im nachfolgenden Fenster als Starttyp „Automatisch“ aus und bestätigen alles mit Klick auf den Button „OK“:

Startart des Dienstes Netzwerkverbindungen ändern

Startart des Dienstes Netzwerkverbindungen ändern

 

Das war es auch schon! Nach einem Neustart des Rechners sollte OpenVPN Client auch unter Windows 8 ohne jegliche Probleme arbeiten.

Wenn Ihnen dieser Artikel gefallen und geholfen hat, können Sie mich gerne unterstützen. Klicken Sie einfach bei Ihrem nächsten Einkauf bei Amazon vorher auf diesen Link Zu Amazon. Das kostet Sie nichts! Alternativ können Sie mir gerne ein kleines Geschenk machen – wenn Sie wollen 🙂
Klicken Sie einfach auf den folgenden Button um meinen Wunschzettel bei Amazon anzuschauen:
wunschliste

Veröffentlicht in Windows Getagged mit: ,
36 Kommentare zu “Klappt garantiert: OpenVPN Client mit Windows 8 – Keine Probleme beim Verbinden
  1. meh sagt:

    Würde den Artikel ja übel feiern, wenn das denn funktionierte.

  2. Norb sagt:

    Einmal die Liste abgearbeitet und schon hat alles prima geklappt.

    Vielen Dank Norbert

  3. StonedMarmot sagt:

    Moin,

    es funktioniert grundsätzlich schon – vielen Dank. Das Problem (zumindest mit meinem Windows 8 Pro, 64-Bit) ist, dass man unter Umständen den fraglichen Service „Network Connections“ einmal stoppen und wieder starten muss, bevor das VPN tatsächlich verbindet. Das ist auch nach dem Befolgen der o.g. Anleitung der Fall – die Regelmäßigkeit, mit der sich das reproduzieren lässt, ist hoch (wenn auch, gefühlt, nicht bei 100% – ich habe es nicht notiert).

    Die sich dann mehrfach wiederholende Status-Meldung des Open-VPN-Client lautet:

    „Route: Waiting for TUN/TAP interface to come up…“

    Letztlich verbindet das VPN anscheinend, die IP ist aber nicht geändert worden.

  4. Hat bestens funktioniert. Gleich beim ersten Mal. Danke für Deine Arbeit!!! Lg CH

  5. Peter sagt:

    Hallo, leider klappt es bei mir nicht. Nach Installation erscheint ein unbekanntes Netzwerk und die Verbindung zum VPN steht. Aber nach einigen Minuten ändert sich der Eintrag im Tray auf „nicht erkanntes Netzwerk, keine Internetverbindung“ und dann geht gar nichts mehr. Muss das VPN abschalten um wieder surfen zu können. Noch eine Idee?

    • Windows 8 hat ziemlich heftige Energiespareinstellungen, die unter anderem z.B. das WLAN deaktivieren, wenn es nach einiger Zeit nicht benutzt wird. Das wiederum führt zu den genannten Problemen.

      Versuch mal Folgendes (und berichte bitte, ob das zum Erfolg oder nicht geführt hat):

      1. Rechtsklick auf Icon Wlan in der Taskleiste
      2. Netzwerk- und Freigabecenter öffnen
      3. Oben links auf Adaptereinstellungen ändern
      4. Rechtsklick auf WiFi
      5. Eigenschaften
      6. Oben rechts auf Konfigurieren
      7. Oben rechts auf Energieverwaltung
      8. Haken weg bei „Computer kann das Gerät ausschalten, um Energie zu sparen“
      9. OK
      10. Fertig

      Viele Grüße,

      Thorsten

  6. rendjy sagt:

    Hallo,

    bei mir hat alles wunderbar funktioniert. Deswegen möchte ich mich an dieser Stelle bei Thorsten ganz herzlich bedanken!

    Ich hab aber folgendes Problem – wenn OpenVPN läuft, habe ich kein Internet. Die verbundenen Netzwerke sind erreichbar aber ich kann keine Internetseiten aufrufen. Wenn ich die Verbindung zum VPN-Account unterbreche, läuft wieder alles ganz normal.

    Woran kann das Problem hier liegen?!
    Vielen Dank im Voraus!

    • Hallo,

      das kann nur an einer fehlerhaften Konfiguration von Server und/oder Client liegen. Falls es nicht sogar eine Überlappung der Netze ist, könnte aber helfen, wenn Du in der Client-Konfiguration den Befehl „redirect-gateway“ rausnimmst oder auskommentierst. Falls der Eintrag nicht vorhanden ist, würde es helfen, mal beide Konfigurations-Dateien zu sehen.

      Viele Grüße,

      Thorsten

  7. Flo.rohmann@web.de sagt:

    Ich hab die Anleitung ebenfalls befolgt, allerdings funktioniert der VPN bei mir nicht. In dem Fenster steht ganz unten immer: MANAGEMENT: >STATE:1381745953,WAIT,,,

    Was is mit diesem „Network Connections“ einmal stoppen und wieder anschalten? Ich kenne mich leider null mit diesem Mist aus, vlt könnt ihr mir weiterhelfen, denn ich komm mit Windows 8 absolut nicht zu Rande… Danke

  8. Jay sagt:

    Hat bestens funktioniert, danke!
    Konnte vorher zwar eine Verbindung aufbauen aber nicht im Internet surfen. Dann konnte ich zwar surfen hatte aber noch die normale IP obwohl OpenVPN verbunden war und das auch anzeigte.

    Also vielen Dank!

  9. Sina sagt:

    Super Anleitung, jedoch klappt es bei mir trotzdem nicht so ganz… Open VPN verbindet nun zwar, jedoch lässt sich die verknüpfte Seite trotzdem nicht öffnen. Muss ich zusätzlich noch irgendwas beachten oder gibt es noch einen Trick? Habe die Anleitung ganz genau befolgt..

    • Hallo Sina, kannst Du denn ausschließen, dass es an der Konfiguration selbst liegt? Sprich: Funktioniert die selbe Konfiguration an einem Windows 7 Rechner? Wenn ja, dann kann es eigentlich nur noch ein DNS-Problem sein. Es könnte in dem Fall sein, dass die Seite nicht korrekt aufgelöst wird. Versuche mal die Seite anzupingen. Notfalls könnte man (falls es am DNS liegt) die entsprechende Seite in die hosts Datei von Windows eintragen. VG, Thorsten

      • Sina sagt:

        Hallo,
        ja die Konfiguration funktioniert an Windows 7 Rechnern. Ich kenn mich leider gar nicht aus und weiß nicht was unter „anpingen“ zu verstehen ist.
        Wie kann ich denn die Seite in die Hosts Datei eintragen?
        Schon mal Danke für die schnelle Antwort.

        • Hallo Sina,

          unter Windows 8 mit Hilfe der Suche nach „cmd“ suchen und das Programm starten (es erscheint ein schwarzes Eingabefenster). Dort kann man mit dem Befehl ping Webseiten anpingen. Also z.B. als Befehl „ping http://www.google.de“ eintippen und Enter/Return/Eingabe drücken. Es kommt dann sowas hier:

          Ping wird ausgeführt für www.google.de [173.194.65.94] mit 32 Bytes Daten:
          Antwort von 173.194.65.94: Bytes=32 Zeit=45ms TTL=49
          Antwort von 173.194.65.94: Bytes=32 Zeit=48ms TTL=49
          Antwort von 173.194.65.94: Bytes=32 Zeit=41ms TTL=49
          Antwort von 173.194.65.94: Bytes=32 Zeit=49ms TTL=49

          Ping-Statistik für 173.194.65.94:
          Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
          (0% Verlust),
          Ca. Zeitangaben in Millisek.:
          Minimum = 41ms, Maximum = 49ms, Mittelwert = 45ms

          C:\Users\Thorsten>

          Wenn stattdessen eine Zeitüberschreitung kommt, bedeutet das, dass der Server nicht erreichbar ist, oder der Name nicht aufgelöst werden kann.

          In Deinem Fall gehe ich von letzterem aus und der Servername muss in die hosts Datei eingetragen werden.

          Die hosts befindet sich unter C:\Windows\System32\drivers\etc und ist normalerweise schreibgeschützt (vor dem Ändern einfach auf den Desktop verschieben und nachher wieder zurück).

          Dort dann einfach den gewünschten Server mit seiner korrekten IP eintragen. z.B.:

          173.194.65.94 www.google.de

          Vorher die richtige IP vom Administrator erfragen.

          Viele Grüße,

          Thorsten

  10. Uwe sagt:

    Hallo Thorsten!
    Nachdem ich deine Anleitung auf meinem PC ausgeführt habe hat es wunderbar funktioniert (Win 8.1 Pro). Nachdem ich nun auf dem Laptop die Anleitung ebenfalls ausgeführt habe, funktioniert es dort nicht. Ebenfalls win 8.1 pro! Die Verbindung wird zwar hergestellt, aber und wieistmeineip.de erscheint immer noch die ursprüngliche ID!! Woran kann es liegen?
    Gruß
    Uwe

    • Hallo Uwe,

      das eine hat mit dem anderen nichts zu tun. Man kann eine VPN-Verbindung so aufbauen, dass man lediglich mit dem entfernten Netz verbunden ist (z.B. um auf die Emails/Daten in der Firma zuzugreifen), oder um seine IP zu verschleiern. Wenn Du möchtest, dass Du mit der IP-Adresse des VPN-Servers im Internet unterwegs bist, musst Du auch das Gateway auf das Gateway vom entfernten Netz legen. Nur dann surfst Du (scheinbar) mit der fremden IP.

      Viele Grüße,

      Thorsten

      • Uwe sagt:

        Vielen Danke für die rasche Antwort!!
        „mit der IP-Adresse des VPN-Servers im Internet unterwegs bist, musst Du auch das Gateway auf das Gateway vom entfernten Netz legen“ …was muß ich da noch ändern, damit ich wie am PC beide „Versionen, dh VPN Tunnel und normale Kabelverbindung“ nutzen kann? Ich weiß mit den IT-Laien ist das immer so eine Sache!! Sorry.
        Herzlichen Gruß
        Uwe

        • Hallo Uwe, sorry für die späte Antwort – ich war ein paar Tage Ski-Fahren. Um die IP des Servers zum Surfen zu nutzen, muss normalerweise in der Konfigurations-Datei des Clients einfach nur die Zeile „redirect-gateway def1“ hinzugefügt werden. Das zwingt den Client dann, sämtlichen Traffic über den VPN-Server zu leiten. Es kann aber sein, dass der Server das wiederum unterbindet. Einfach mal ausprobieren! Viele Grüße, Thorsten

      • UWE sagt:

        „musst Du auch das Gateway auf das Gateway vom entfernten Netz legen. Nur dann surfst Du (scheinbar) mit der fremden IP.“

        Wie/Wo kann ich die Einstellung vornehmen? Die Einstellung sollte nur temporär sein und bei der „normalen“ Kabelverbindung die ursprüngliche einstellung gelten.

        Herzlichen Gruß
        Uwe

  11. Nico sagt:

    Hallo Thorsten,

    danke für die gute Beschreibung – habe alles ausgeführt und komme trotzdem nicht zum Ziel. Sony Vaio, Win8, open vpn 2.3.6.

    Nach Start von open vpn gui habe ich zwar das Icon auf der Taskleiste, dieses reagiert aber nur auf Rechtsklick und ich kann „Einstellungen“ vornehmen. Andere Optionen gibt es nicht.

    Was mach ich falsch?

    Viele Grüße
    Nico

  12. Siegmar Zander sagt:

    Hallo Thorsten,

    danke sehr für die Beschreibung, habe alles genauso ausgeführt, aber bei mir startet die GUI nicht. Ich muss die Administratorrechte bestätigen, und dann passiert nichts mehr.

    Ich habe das mit div. Versionen (letzte aktuelle und auch etwas ältere) getestet, aber immer das gleiche Verhalten.

    ASUS Vivo Tab mit Windows 8.1(Bing)

    Gibt es dazu irgend eine gute Idee?

    Danke vorab
    Siegmar

  13. Siegmar Zander sagt:

    Danke für die schnelle Antwort. Ja natürlich ist das so.
    Gruß
    Siegmar

  14. Uwe sagt:

    Hallo Thorsten!
    Erst einmal danke für die vielen Tipps.
    Hab nun OpenVPN GUI auf einem neuen Rechner Win10 64bit installiert. Deiner Anleitung nach vorgegangen. Ich erhalte aber immer die Meldung „Verbindung fehlgeschlagen“. Die Zugangsdaten sind aber OK.
    Danke für deinen Tipp!
    Gruß
    Uwe

  15. JürgenD sagt:

    … mit der Konfig oder mit dem was vom Server zurück kommt.

    Ich bin bei hide.me und von dort kommt folgendes zurück:

    PUSH: Received control message: ‚PUSH_REPLY,dhcp-option DNS 178.162.201.13,dhcp-option DNS 178.162.201.14,ping 5,ping-restart 15,explicit-exit-notify,route-gateway 10.3.55.98,redirect-gateway,ifconfig 10.3.55.98 255.255.255.0‘

    Dann beschwert sich Openvpn folgendermaßen:

    Since you are using –dev tun with a point-to-point topology, the second argument to –ifconfig must be an IP address. You are using something (255.255.255.0) that looks more like a netmask.

    There is a problem in your selection of –ifconfig endpoints [local=10.3.55.98, remote=255.255.255.0]. The local and remote VPN endpoints must exist within the same 255.255.255.252 subnet. This is a limitation of –dev tun when used with the TAP-WIN32 driver. Try ‚openvpn –show-valid-subnets‘ option for more info.

    Ich kenn mich jetzt überhaupt nicht in diesem Thema aus, ob ich dies selber beeinflussen kann und muss mich dann wohl mal an hide.me wenden.

    Vielleicht fällt dir noch was ein.

    Vielen Dank.
    Jürgen

    • Dann ist das aber eindeutig ein hide.me Problem. Irgendwas pushen die falsch. Um es einzugrenzen: Deaktiviere mal das WLAN (falls Du mit Notebook unterwegs bist) und stelle eine LAN-Verbindung her. Wenn das klappen sollte, deaktiviere als nächstes am Router eine von beiden Frequenzbändern (5 oder 2,4 GHz), so dass Dein Windows nur noch die Möglichkeit hat sich mit genau einem Netzwerk zu verbinden, und teste wieder mit WLAN.

1 Pings/Trackbacks für "Klappt garantiert: OpenVPN Client mit Windows 8 – Keine Probleme beim Verbinden"
  1. […] unter Windows 8 mit OpenVPN ins Firmennetz tunnelt, der stößt bei der Installation auf mancherlei Problemchen. Außerdem ist OpenVPN GUI (angefangen beim verpixelten Icon) typisch hässliche, wenn auch […]

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*